logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
machtool  
#1 Posted : Wednesday, July 01, 2020 2:10:20 PM(UTC)
machtool

Rank: Guest

Joined: 6/17/2017(UTC)
Posts: 9

Thanks: 1 times
I am having on going issues when trying to align simple parts. The first 1 or 2 attempts will work. then Align stops working. after a few more failed attempts to align the program will usually shut down.
The only cure i found is to do a COMPACT before trying to align, it gets tedious having to do this.
any help is appreciated
It is Build 12441
magicart  
#2 Posted : Wednesday, July 01, 2020 10:59:55 PM(UTC)
magicart

Rank: Guest

Joined: 6/20/2015(UTC)
Posts: 170
Man
Poland

Thanks: 59 times
Was thanked: 48 time(s) in 29 post(s)
Hi Machtool,

nothing changed since v8. This issue was reported several times, never has been fixed. This tool is good for two solids and single action - no more, and You have to remove history tree after use it, otherwise it will demolish Your assemblies when You move parts. If you want to build assembly from 3 or more solids use other tools - magnet tool + gripper - for example, or rotate it, grasp corner and move to another corner. These actions have no links so you will not blow Your assembly up.

BTW
You don't have to compact Your file, You need to only "remove links".

Magicart

Edited by user Wednesday, July 01, 2020 11:02:53 PM(UTC)  | Reason: Not specified

thanks 2 users thanked magicart for this useful post.
MPSchmied on 7/2/2020(UTC), machtool on 7/2/2020(UTC)
machtool  
#3 Posted : Thursday, July 02, 2020 7:00:32 AM(UTC)
machtool

Rank: Guest

Joined: 6/17/2017(UTC)
Posts: 9

Thanks: 1 times
Thank you for the help here, I contacted tech support on this issue and they told me they could not replicate the issue on their system.
how do i remove links ? thru the compact tool?
RE: magnet + gripper tool, not sure how this works, can you explain


Originally Posted by: magicart Go to Quoted Post
Hi Machtool,

nothing changed since v8. This issue was reported several times, never has been fixed. This tool is good for two solids and single action - no more, and You have to remove history tree after use it, otherwise it will demolish Your assemblies when You move parts. If you want to build assembly from 3 or more solids use other tools - magnet tool + gripper - for example, or rotate it, grasp corner and move to another corner. These actions have no links so you will not blow Your assembly up.

BTW
You don't have to compact Your file, You need to only "remove links".

Magicart


MPSchmied  
#4 Posted : Thursday, July 02, 2020 12:40:06 PM(UTC)
MPSchmied

Rank: Guest

Joined: 4/9/2017(UTC)
Posts: 335
Man
Germany

Thanks: 118 times
Was thanked: 35 time(s) in 29 post(s)
File> Compact> "Remove History" for global removing
Alternative:

Edit> "Remove Links" for partially removing.
OS: Windows
magicart  
#5 Posted : Friday, July 03, 2020 12:28:04 AM(UTC)
magicart

Rank: Guest

Joined: 6/20/2015(UTC)
Posts: 170
Man
Poland

Thanks: 59 times
Was thanked: 48 time(s) in 29 post(s)
Originally Posted by: machtool Go to Quoted Post

how do i remove links ? thru the compact tool?
RE: magnet + gripper tool, not sure how this works, can you explain



Hi Machtool,

I use a combination of "magnet tool" and gripper when "align tool" falls. Usually I do this when I need to place two parts together vertically or horizontally (in reference to selected part's surface - not axis). In this case "magnet tool" gives me that two parts are oriented in the same way in space (selected part's surfaces are tangential), while gripper (or grasp and move technique) is needed to set two parts properly - because "magnet tool" always place objects in a center.

Magicart

Edited by user Friday, July 03, 2020 12:40:47 AM(UTC)  | Reason: Not specified

thanks 2 users thanked magicart for this useful post.
L. Banasky on 7/3/2020(UTC), GARLIC on 7/3/2020(UTC)
MPSchmied  
#6 Posted : Sunday, July 05, 2020 11:09:01 AM(UTC)
MPSchmied

Rank: Guest

Joined: 4/9/2017(UTC)
Posts: 335
Man
Germany

Thanks: 118 times
Was thanked: 35 time(s) in 29 post(s)
Originally Posted by: magicart Go to Quoted Post
when "align tool" falls
in Build 1162 works the align-tool very good.

OS: Windows
magicart  
#7 Posted : Monday, July 06, 2020 3:12:51 PM(UTC)
magicart

Rank: Guest

Joined: 6/20/2015(UTC)
Posts: 170
Man
Poland

Thanks: 59 times
Was thanked: 48 time(s) in 29 post(s)
Originally Posted by: MPSchmied Go to Quoted Post
in Build 1162 works the align-tool very good.




Unless I see it I will not believe :-)))))

Magicart
thanks 1 user thanked magicart for this useful post.
Christian Hallauer on 7/20/2020(UTC)
MPSchmied  
#8 Posted : Tuesday, July 07, 2020 8:12:13 AM(UTC)
MPSchmied

Rank: Guest

Joined: 4/9/2017(UTC)
Posts: 335
Man
Germany

Thanks: 118 times
Was thanked: 35 time(s) in 29 post(s)
Originally Posted by: magicart Go to Quoted Post

Unless I see it I will not believe :-)))))

Magicart


The problem is: I work the most time with removed links. So maybe there are issues which i not see. The History is everytime small in my files. But 1162 have no magnet tool and the align tool is the only way for assembling items. But yes, the other way is moving and rotating the items...... But this is more work. In V10 i detected also problems with the magnet tool. Never use Undo and the magnet tool :) Never use undo!

Edited by user Tuesday, July 07, 2020 8:17:02 AM(UTC)  | Reason: Not specified

OS: Windows
magicart  
#9 Posted : Tuesday, July 07, 2020 2:40:56 PM(UTC)
magicart

Rank: Guest

Joined: 6/20/2015(UTC)
Posts: 170
Man
Poland

Thanks: 59 times
Was thanked: 48 time(s) in 29 post(s)
Originally Posted by: MPSchmied Go to Quoted Post
I work the most time with removed links. So maybe there are issues which i not see... ...Never use undo!



You're right! When you remove links in every 5 steps, do not move/rotate your assembly, avoid undo and use align tool with two, three solids then it ok. Sometimes it doesn't work even with steps above, but usually it's ok. To be honest - these steps you mentioned are necessary with 80% of other tools :-)

Magicart

MPSchmied  
#10 Posted : Sunday, July 19, 2020 4:29:27 AM(UTC)
MPSchmied

Rank: Guest

Joined: 4/9/2017(UTC)
Posts: 335
Man
Germany

Thanks: 118 times
Was thanked: 35 time(s) in 29 post(s)
I have the error reproduced in Build 1162, and i remember me in the past i thought it works not because i make something wrong, but no, it just works not, and it works only again when the history deleted.

The Magnet tool is good, thats at time the only reason why i use Shark 10 sometimes, just to use the Magnet Tool. But Shark 10 is a downgrade because the In Stream Zoom Commands are less in stream and the inspector is slower.

@Development: Why???? Is this software developed in Japan and the japanese and chinese developers on strike?

I know that a new alpha version have new bugs, also other devs have always this problem. But the problem is, this new bugs stay forever. Some bugs will be fexed but never all, so there will be more and more bugs which stay forever. Sometimes there will be so many bugs that it is no longer usable and it is because of thie bugs sometimes a Time Destruction Machine.

Edited by user Monday, July 20, 2020 6:08:20 AM(UTC)  | Reason: Not specified

OS: Windows
thanks 1 user thanked MPSchmied for this useful post.
magicart on 7/19/2020(UTC)
Users browsing this topic
Guest (3)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.