logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
scloutier  
#1 Posted : Tuesday, December 15, 2020 6:00:21 AM(UTC)
scloutier

Rank: Guest

Joined: 12/15/2020(UTC)
Posts: 2

Was thanked: 2 time(s) in 2 post(s)
I'm snapping tangents to connect two circles. Everything looks fine till I zoom in and the tangents are not actually touching the circles which leaves me with a gap.
I've tried changing the resolution but this does not work...
Thanks for any advise.
thanks 1 user thanked scloutier for this useful post.
specktech on 6/14/2021(UTC)
jdi000  
#2 Posted : Tuesday, December 15, 2020 6:21:12 AM(UTC)
jdi000

Rank: Administration

Joined: 7/29/2007(UTC)
Posts: 1,857
United States

Thanks: 1 times
Was thanked: 84 time(s) in 78 post(s)
Originally Posted by: scloutier Go to Quoted Post
I'm snapping tangents to connect two circles. Everything looks fine till I zoom in and the tangents are not actually touching the circles which leaves me with a gap.
I've tried changing the resolution but this does not work...
Thanks for any advise.


Hello

Sounds like a visual,if you can use select chain on the line and and it grabs all the circles then they are sharing same point even though it's not visual on the screen. What display mode are you using?

Regards

Jason
Windows 10, Win 7
thanks 1 user thanked jdi000 for this useful post.
specktech on 6/14/2021(UTC)
scloutier  
#3 Posted : Tuesday, December 15, 2020 6:50:58 AM(UTC)
scloutier

Rank: Guest

Joined: 12/15/2020(UTC)
Posts: 2

Was thanked: 2 time(s) in 2 post(s)
Thanks for the reply, I'm fairly new at this.

I selected one of the lines then used the select chain in the edit menu and nothing seemed to happen. I also tried select all with select chain and nothing. Still gaps when I zoom in or try and extrude.

I'm using the top view as this is in 2D.
thanks 1 user thanked scloutier for this useful post.
specktech on 6/14/2021(UTC)
jdi000  
#4 Posted : Thursday, December 17, 2020 1:13:16 PM(UTC)
jdi000

Rank: Administration

Joined: 7/29/2007(UTC)
Posts: 1,857
United States

Thanks: 1 times
Was thanked: 84 time(s) in 78 post(s)
Originally Posted by: scloutier Go to Quoted Post
Thanks for the reply, I'm fairly new at this.

I selected one of the lines then used the select chain in the edit menu and nothing seemed to happen. I also tried select all with select chain and nothing. Still gaps when I zoom in or try and extrude.

I'm using the top view as this is in 2D.



Hello

Can you copy out an example and upload it here?

Regards

Jason
Windows 10, Win 7
thanks 1 user thanked jdi000 for this useful post.
specktech on 6/14/2021(UTC)
mitchb  
#5 Posted : Thursday, December 17, 2020 7:37:35 PM(UTC)
mitchb

Rank: Guest

Joined: 4/29/2015(UTC)
Posts: 62

Thanks: 1 times
Was thanked: 36 time(s) in 23 post(s)
I'm not clear as to which tangent you are using. There is a logic cursor tangent and a constraint tangent. The constraint tangent doesn't need the line to touch the circle, it can be tangent with the circle but not necessarily tangent on the circle. In this case, use the extend tool to intersect the circle. If the line extends past the circle, use the trim tool.

To use the logic cursor select the line tool and move your cursor over the circle and look for the word "on" to popup, only the on should be seen. Click, hold, and drag away from the circle then pause, the word "tangent" should popup. Continue dragging to the second circle and follow the circle edge until "tangent" pops up again, release the mouse. Click and hold is the key for this to work. Another option here is to drag the mouse away from the circle at 90° and the word "perpendicular" will popup. This is will give you a line perpendicular to the circle.
thanks 1 user thanked mitchb for this useful post.
specktech on 6/14/2021(UTC)
gebhardt  
#6 Posted : Friday, December 18, 2020 5:53:44 AM(UTC)
gebhardt

Rank: Guest

Joined: 4/10/2018(UTC)
Posts: 18
Man
Location: Switzerland

Thanks: 1 times
Was thanked: 8 time(s) in 5 post(s)
If cursor show tangent on both end whilst drawing its is tangent. Might be ea resolution issue. Mark all questionable elements , go to "edit" menu > "change resolution" > set elements to "super fine" . also set "even distribution" for these elements.
thanks 1 user thanked gebhardt for this useful post.
specktech on 6/14/2021(UTC)
posh.de  
#7 Posted : Friday, December 18, 2020 8:46:24 AM(UTC)
posh.de

Rank: Senior Member

Joined: 2/23/2007(UTC)
Posts: 462
Man
Germany

Thanks: 11 times
Was thanked: 37 time(s) in 29 post(s)
the visualization on the display (with it's limited resolution) does in general not represent the true geometric model, i.e. will show gaps etc. if zooming far enough in. Therefore geometry and their construction points and geometric relationships shouldn't be evluated by trying to zoom in to extreme zoom scales but by using the snapping and coordinates shown by the 'Inspector' only.

POSH GmbH
www.posh.de
thanks 1 user thanked posh.de for this useful post.
specktech on 6/14/2021(UTC)
rockyroad_us  
#8 Posted : Friday, December 18, 2020 8:58:43 AM(UTC)
rockyroad_us

Rank: Senior Member

Joined: 9/12/2009(UTC)
Posts: 571
Man
United States
Location: In my place

Was thanked: 44 time(s) in 41 post(s)
It sounds like a graphics card issue. if you trim at the tangent locations, it will smooth out.
FX 7-10 Pro12-1592
Mac 11.6.2
2x2.8GHz Quad Xeon
32GB
Radeon HD7970 3GB
Work
thanks 1 user thanked rockyroad_us for this useful post.
specktech on 6/14/2021(UTC)
MaiFy  
#9 Posted : Monday, December 21, 2020 10:46:17 PM(UTC)
MaiFy

Rank: Senior Member

Joined: 10/3/2014(UTC)
Posts: 112
Australia

Thanks: 28 times
Was thanked: 29 time(s) in 19 post(s)
Hi there
My 2 cents worth.

Some times I use the corner trim tool or (trim 2 entities tool at corners tool)
That rejoins the lines seamlessly.
If it doesn't rejoin it often means I have gone out of 2D mode and slipped into 3D mode and it wont trim because I am in a different plane.
The lines might look all good to trim but the lines are not even close. ((Try holding down AlT with your left hand, hold down right click and drag mouse at the same time,)) Press "D" to return to normal, (anyway thats how my shortcuts work.)
With the circles I use the break tool on the inside of the object, generally in 2 places near where I want to trim, the reason for that is that the circle lines have directional memories and the trim at corners tool can delete parts of the circle that you want.
It you break it in 2 places it generally stops this.

Little vid explaining what I mean

😉👍
thanks 3 users thanked MaiFy for this useful post.
L. Banasky on 12/22/2020(UTC), specktech on 6/14/2021(UTC), GARLIC on 6/15/2021(UTC)
specktech  
#10 Posted : Monday, June 14, 2021 9:41:37 PM(UTC)
specktech

Rank: Guest

Joined: 4/20/2021(UTC)
Posts: 38

Thanks: 253 times
Was thanked: 8 time(s) in 7 post(s)
This is exactly the same problem I am having. I am doing the tangent process exactly like it should be done and getting gaps. Trying everything possible to get this dialed in. Gonna watch your vid MaiFy.


Thank you so much for making this little video. This is the exact same thing that I was struggling with. Watched it about 5 times. Think I got the fix in my head now. Just need to try it out. Thank you so much Maify. Going to watch all the other vids you have on Vimeo. Peace out.

In reading your explanation a few times over, You have really steered me in the right direction. Thank you 100 times Maify. I would have never figured this out with out your help. Going to get this dialed now. Big smiles Maify.

Wanted to thank all the other posts on this subject on this page. I read every word a few times over. And I think I am slowly getting my head wrapped around this. Thanks ViaCAD and Shark users.

Edited by user Monday, June 14, 2021 10:21:16 PM(UTC)  | Reason: Maify made me edit it 3 times. Thanks

thanks 1 user thanked specktech for this useful post.
MaiFy on 6/22/2021(UTC)
MPSchmied  
#11 Posted : Thursday, June 17, 2021 4:42:09 AM(UTC)
MPSchmied

Rank: Guest

Joined: 4/9/2017(UTC)
Posts: 404
Man
Germany

Thanks: 168 times
Was thanked: 74 time(s) in 56 post(s)
Originally Posted by: specktech Go to Quoted Post
I am doing the tangent process exactly like it should be done and getting gaps
I am not able to recreate this issue. I get no real gaps when it snapping the right way. Maybe use the trim tool to remove the unneeded parts of the circles.

Edited by user Thursday, June 17, 2021 4:48:50 AM(UTC)  | Reason: Not specified

MPSchmied attached the following image(s):
Zwischenablage01.png (18kb) downloaded 2 time(s).

You cannot view/download attachments. Try to login or register.
OS: Windows
thanks 1 user thanked MPSchmied for this useful post.
specktech on 7/19/2021(UTC)
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.