logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Albatrossflyer  
#1 Posted : Tuesday, August 04, 2020 9:54:03 AM(UTC)
Albatrossflyer

Rank: Member

Joined: 7/21/2008(UTC)
Posts: 35

Was thanked: 1 time(s) in 1 post(s)
This pertains to MacOS versions of SCPro 11 and older versions.

I have a number of old files created with Shark FX v8 SP2. These files will not open in SCPro 11 and either cause the SCPro 11 to hang or flat out crash. (They still open fine on an old computer with FX v8 on it. So they're not corrupted.)

I have also tried importing the files into SCPro 11 using both the import type "SharkCAD Pro" and "Punch! Objects" with no luck.

I believe some of these files opened with SCPro 10 but I"m not sure. Unfortunately I removed SCPro 10 from my current computer after upgrading to 11.

Any ideas?
jlm  
#2 Posted : Wednesday, August 05, 2020 3:12:28 AM(UTC)
jlm

Rank: Senior Member

Joined: 2/18/2007(UTC)
Posts: 1,098
Man
France
Location: Paris & Frankfurt

Thanks: 101 times
Was thanked: 72 time(s) in 47 post(s)
Originally Posted by: Albatrossflyer Go to Quoted Post
This pertains to MacOS versions of SCPro 11 and older versions.

I have a number of old files created with Shark FX v8 SP2. These files will not open in SCPro 11 and either cause the SCPro 11 to hang or flat out crash. (They still open fine on an old computer with FX v8 on it. So they're not corrupted.)

I have also tried importing the files into SCPro 11 using both the import type "SharkCAD Pro" and "Punch! Objects" with no luck.

I believe some of these files opened with SCPro 10 but I"m not sure. Unfortunately I removed SCPro 10 from my current computer after upgrading to 11.

Any ideas?


I don't have this issue with my old files.
Just checked : with Viacad V11 and with Sharkcad Pro V12 too, I can open files made in 2010 (Not shure of the version it was 10 years ago, but certainly below 8...)

Worth to be noticed :
I can still open directly CU files dated 2004 with Sharkcad V12 (Concept Unlimited was ancestor of Shark)...

Sorry, it doesn't help you much.
There may be some incompatible content in your files.

Tim or Todd could maybe help you.

JL
Albatrossflyer  
#3 Posted : Sunday, August 09, 2020 2:11:45 PM(UTC)
Albatrossflyer

Rank: Member

Joined: 7/21/2008(UTC)
Posts: 35

Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: jlm Go to Quoted Post
Originally Posted by: Albatrossflyer Go to Quoted Post
This pertains to MacOS versions of SCPro 11 and older versions.

I have a number of old files created with Shark FX v8 SP2. These files will not open in SCPro 11 and either cause the SCPro 11 to hang or flat out crash. (They still open fine on an old computer with FX v8 on it. So they're not corrupted.)

I have also tried importing the files into SCPro 11 using both the import type "SharkCAD Pro" and "Punch! Objects" with no luck.

I believe some of these files opened with SCPro 10 but I"m not sure. Unfortunately I removed SCPro 10 from my current computer after upgrading to 11.

Any ideas?


I don't have this issue with my old files.
Just checked : with Viacad V11 and with Sharkcad Pro V12 too, I can open files made in 2010 (Not shure of the version it was 10 years ago, but certainly below 8...)

Worth to be noticed :
I can still open directly CU files dated 2004 with Sharkcad V12 (Concept Unlimited was ancestor of Shark)...

Sorry, it doesn't help you much.
There may be some incompatible content in your files.

Tim or Todd could maybe help you.

JL


Jim

Did you upgrade to Catalina (10.15) with the new APFS file system? I'm wondering if my issue is related to my old CAD files being created and saved under the old HFS+ file system and not working under APFS now.
jlm  
#4 Posted : Sunday, August 09, 2020 11:15:00 PM(UTC)
jlm

Rank: Senior Member

Joined: 2/18/2007(UTC)
Posts: 1,098
Man
France
Location: Paris & Frankfurt

Thanks: 101 times
Was thanked: 72 time(s) in 47 post(s)
Originally Posted by: Albatrossflyer Go to Quoted Post
Originally Posted by: jlm Go to Quoted Post

Jim
Did you upgrade to Catalina (10.15) with the new APFS file system? I'm wondering if my issue is related to my old CAD files being created and saved under the old HFS+ file system and not working under APFS now.


Yes I'm on Catalina.
I don't think it is related to the file system :
In 2004 I was using Panther (MacOS 10.3) on a G4 PowerMac and the files can still be open...
Albatrossflyer  
#5 Posted : Friday, September 25, 2020 12:26:25 PM(UTC)
Albatrossflyer

Rank: Member

Joined: 7/21/2008(UTC)
Posts: 35

Was thanked: 1 time(s) in 1 post(s)
After mucking around a fair bit and with less than zero help from tech support, I finally got to the bottom of my problem. I have a jpg of my company logo embedded in my border layer which appears to cause V11 to hang / crash on opening. I deleted the jpg with V10, saved the file, and now they all open in V11 without a hitch.

Users browsing this topic
Guest (2)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.