logo
NOTICE:  This is the new PunchCAD forum. You should have received an email with your new password around August 27, 2014. If you did not, or would like it reset, simply use the Lost Password feature, and enter Answer as the security answer.
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Bogwind  
#1 Posted : Saturday, August 08, 2020 1:03:50 PM(UTC)
Bogwind

Rank: Junior Member

Joined: 11/21/2014(UTC)
Posts: 2
United States

Hello, everyone! I have found some strange behavior that I think is a bug and I was hoping someone else in the forum would be willing to follow these steps and try to reproduce the problem on their system.

My System Details:
ViaCad Pro v12.0.0 (Build 1536), with PowerPack
MacBook Pro 2.9ghz Core i7, 16GB, OSX Mojave v10.14.6

I've been using this same computer to run ViaCad Pro 10 and ViaCad Pro 11 for a couple of years. I updated to ViaCad Pro 12 a few weeks ago.

The problem I'm seeing is ViaCad 12 reporting the wrong dimensions for objects when working with UNITS set to "feet/inches"

Here are the steps to reproduce what I've seen:

1) Start a new project
2) Go into ViaCad->Preferences->Units and set units to "Inches", Apply
3) Choose the BLOCK PRIMITIVE tool, configure it for BLOCK ONE POINT and create a cube that's 3.5 x 3.5 x 3.5 inches
4) Select the cube and verify its size in the INSPECTOR. Inspector should report the correct size for the cube (3.5^3)
5) Go into ViaCad->Preferences->Units and switch UNITS to "feet/inches", Apply
6) Select the cube and verify its size in the INSPECTOR. Inspector should now report the cube's size as 4-1/2" x 4-1/2" x 4-1/2"

The cube itself has not changed- If you switch UNITS back to INCHES, the inspector will report the correct dimensions again. So this appears to be a problem with converting or displaying dimensions when UNITS is set to "feet/inches".

It would be great to know if anyone else is able to reproduce this problem so we can get it submitted as a bug. I usually work with UNITS set to millimeters, designing parts for 3D printing and laser cutting. Lately I've been using ViaCad to design a chicken coop so it makes more sense to work with feet/inches when dealing with dimensional lumber but it's not possible to work when the software is reporting the wrong dimensions for objects!



Bogwind attached the following image(s):
correct_dimensions.png (229kb) downloaded 1 time(s).
wrong_dimensions.png (234kb) downloaded 1 time(s).

You cannot view/download attachments. Try to login or register.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.